Dreamweaver MX 2004

Working with Libraries
Table of Contents

Using the Assets panel .................................................................................................................. 3
Viewing Assets in the Assets panel .............................................................................................. 4

Working with Library Items ........................................................................................................... 6
Creating a library item .................................................................................................................. 6
Inserting a library item in a document ......................................................................................... 7
Editing a library item .................................................................................................................... 8
Making library items editable in a document .............................................................................. 11
Editing the properties for a library item ..................................................................................... 11
Setting Library item properties ................................................................................................. 12
Using the Assets panel

Assets include a variety of elements that you store in a site, such as an image or movie file. The Assets panel provides two ways to view assets:

The Site list shows all of the assets in your site.

The Favorites list shows only the assets you’ve explicitly chosen.

In both lists, assets are divided into the following categories, which appear on the left side of the Assets panel:

- **Images** are image files in GIF, JPEG, or PNG formats.
- **Colors** are the colors that are used in documents and style sheets in your site, including text colors, background colors, and link colors.
- **URLs** are the external links in your current site documents. This category includes the following types of links: FTP, gopher, HTTP, HTTPS, JavaScript, e-mail (mailto), and local file (file://)
- **Flash** files are files in any version of Macromedia Flash format. The Assets panel displays only SWF files (compressed Flash files), but not FLA (Flash source) files.
- **Shockwave movies** are files in any version of Macromedia Shockwave format. **Movies** are files in QuickTime or MPEG format. **Scripts** are JavaScript or VBScript files.
- **Templates** provide an easy way to reuse the same page layout on multiple pages and to modify the layout on all pages attached to a template when a template is modified.
- **Library items** are elements that you use in multiple pages; when you modify a library item, all pages that contain that item are updated.
Viewing Assets in the Assets panel

You can view and manage assets in the current site using the Assets panel. The Assets panel displays assets for the site associated with the active document in the Document window.

Note: You must define a local site before you can view assets in the Assets panel. For more information about setting up a site.

The Assets panel provides two views:

- **The Site list** shows all of the assets in your site, including colors and URLs that are used in any document in your site.

- **The Favorites list** shows only the assets you’ve explicitly chosen.

In both lists, assets are divided into categories (along the left side of the Assets panel). The Site list and the Favorites list are both available for all categories of assets except templates and library items.

Note: Most of the Assets panel operations work the same in the Site list and in the Favorites list. There are a few tasks, however, that you can perform only in the Favorites list.

By default, assets in a given category are listed in alphabetical order by name. You can instead list the assets by any of several other criteria or change the size of the columns. You can also preview assets in a category, and change the size of the preview area.

To open the Assets panel:

- Select Window > Assets.

The Assets panel appears. By default, the Images category is selected.

To view the Site list:

- In the Assets panel (Window > Assets), select the Site option at the top of the panel.
Note: In the Templates and Library categories (on the left side of the Assets panel), the Site and Favorites choices are unavailable.

To view the Favorites list:

- In the Assets panel (Window > Assets), select the Favorites option at the top of the panel. The Favorites list is empty until you explicitly add assets to it.

Note: In the Templates and Library categories (on the left side of the Assets panel), the Site and Favorites choices are unavailable.

To display assets in a particular category:

- Click the appropriate icon on the left side of the Assets panel (Window > Assets).

To list assets in a different order:

- Click one of the column headings.

  For example, to sort the list of images by type (so that all the GIF images are together, all the JPEG images are together, and so on), click the Type column heading.

To change the width of a column:

- Drag the line that separates two column headings.

To preview an asset:

- Select the asset in the Assets panel.

  The preview area at the top of the panel shows a visual preview of the asset.

  For example, when you select a movie asset, the preview area shows an icon. To view the movie, click the Play button (the green triangle) in the upper right corner of the preview area.

To change the size of the preview area:

- Drag the splitter bar (between the preview area and the list of assets) up or down.
Working with Library Items

Libraries are a way to store page elements such as images, text, and other objects that you want to reuse or update frequently throughout your website. A library is a special Dreamweaver file that contains a collection of individual assets or copies of assets you have created for placement in your web pages. These assets in a library are called library items. You can update all the pages that use a library item whenever you change the item’s contents. You can store all sorts of page elements, such as images, tables, sounds, and Flash files in a library.

Creating a library item

You can create a library item from any element in the body section of a document, including text, tables, and images.

For linked items such as images, the library stores only a reference to the item. The original file must remain at the specified location for the library item to work correctly.

To create a library item based on a selection:

1. In the Document window, select a portion of a document to save as a library item.

2. Click the New Library Item button at the bottom of the Library category of the Assets panel (Window > Assets).

3. Type a name for the new library item, then press Enter (Windows) or Return (Macintosh).

   Dreamweaver saves each library item as a separate file (with the file extension .lbi) in the Library folder of the site’s local root folder.

To create an empty library item:

1. Make sure nothing is selected in the Document window.

   If something is selected, it will be placed in the new library item.

2. In the Assets panel (Window > Assets), select the Library category on the left side of the panel.
Dreamweaver Libraries

3. Click the New Library Item button at the bottom of the Assets panel. A new, untitled library item is added to the list in the panel.

4. While the item is still selected, enter a name for it, then press Enter (Windows) or Return (Macintosh).

---

Inserting a library item in a document

When you add a library item to a page, the actual content is inserted in the document along with a reference to the library item.

To insert a library item in a document:

1. Place the insertion point in the Document window.

2. In the Assets panel (Window > Assets), select the Library category on the left side of the panel.

3. Do one of the following:
   - Drag a library item from the Assets panel to the Document window.
Tip: To insert the contents of a library item without including a reference to the item in the document, press Control (Windows) or Option (Macintosh) while dragging an item out of the Assets panel. If you insert an item this way, you can edit the item in the document, but the document won’t update when you update pages that use that library item.

- Select a library item, then click the Insert button at the bottom of the panel.

**Editing a library item**

When you edit a library item, you can update all documents that use that item. If you choose not to update, the documents remain associated with the library item; you can update them later.

Other kinds of changes to library items include renaming items to break their connection with documents or templates, deleting items from the site’s library, and recreating a missing library item.

**Note:** The CSS Styles panel is unavailable when you are editing a library item, since library items can contain only `body` elements and CSS style sheet code inserts in the `head` section of a document. The Page Properties dialog box is also unavailable, because a library item can’t include a `body` tag or its attributes.

**To edit a library item:**

1. In the Assets panel (Window > Assets), select the Library category on the left side of the panel.

2. Select a library item.

   A preview of the library item appears at the top of the Assets panel. (You can’t edit anything in the preview.)

3. Do one of the following:
   - Click the Edit button at the bottom of the panel.
   - Double-click the library item.

Dreamweaver opens a new window for editing the library item. This window is much like a Document window, but its Design view has a gray background to indicate that you’re editing a library item instead of a document.
4. Edit the library item, then save your changes.

5. In the dialog box that appears, select whether to update the documents on the local site that uses the edited library item:
   - Select Update to update all documents in the local site with the edited library item.
   - Select Don’t Update to avoid changing any documents until you use Modify > Library > Update Current Page or Update Pages.

To update the current document to use the current version of all library items:

- Select Modify > Library > Update Current Page.

To update the entire site or all documents that use a particular library item:

1. Select Modify > Library > Update Pages.

   The Update Pages dialog box appears.

2. In the Look In pop-up menu, do one of the following:
   - Select Entire Site, then select the site name from the adjacent pop-up menu.
     This updates all pages in the selected site to use the current version of all library items.
   - Select Files That Use, then select a library item name from the adjacent pop-up menu.
     This updates all pages in the current site that use the selected library item.

3. Make sure Library Items is selected in the Update option.

   **Tip:** To update templates at the same time, make sure Templates is also selected.

   Click Start.

   Dreamweaver updates the files as indicated. If you selected the Show Log option, Dreamweaver provides information about the files it attempts to update, including information on whether they were updated successfully.
To rename a library item:

1. In the Assets panel (Window > Assets), select the Library category on the left side of the panel.
2. Select the library item you want to rename, pause, then click again.
3. When the name becomes editable, enter a new name.

   Note: This method of renaming works the same way that renaming a file in Windows Explorer (Windows) or the Finder (Macintosh) does. As with Windows Explorer and the Finder, make sure to pause briefly between clicks. Do not double-click the name; that opens the library item for editing.

4. Click elsewhere, or press Enter (Windows) or Return (Macintosh).
5. Dreamweaver asks if you want to update documents that use the item:
   - To update all documents in the site that use the item, click Update.
   - To refrain from updating any documents that use the item, click Don’t Update.

To delete a library item from a library:

1. In the Assets panel (Window > Assets), select the Library category on the left side of the panel.
2. Select the library item you want to delete.
3. Do one of the following:
   - Click the Delete button at the bottom of the panel, then confirm that you want to delete the item.
   - Press the Delete key, then confirm that you want to delete the item.

   Caution: Be careful; if you delete a library item, you can’t use Undo to retrieve it. You may be able to recreate it, however, as described in the next procedure.

Dreamweaver removes the library item from the library, but doesn’t change the contents of any documents that use the item.
To recreate a missing or deleted library item:

1. Select an instance of the item in one of your documents.
2. Click the Recreate button in the Property inspector (Window > Properties).

Making library items editable in a document

If you’ve added a library item to your document and you want to edit the item specifically for that page, you must break the link between the item in the document and the library. Once you’ve made an instance of a library item editable, that instance cannot be updated when the library item changes.

To make a library item editable:

1. Select a library item in the current document.
2. Click Detach from Original in the Property inspector (Window > Properties).

The selected instance of the library item loses its highlighting (if you had highlighting visible), and can no longer be updated when the original library item changes.

Editing the properties for a library item

You can use the Property inspector for a library item to open a library item for editing, detach a selected library item from its source file, or overwrite an item with the currently selected library item.

To edit the properties for a library item:

1. Select a library item in a document.
2. Click one of the buttons in the Property inspector (Window > Properties), depending on what you want to do.
Setting Library item properties

Use library item properties to specify the source file of an item, to make it editable, or to re-create the original library item after editing an instance of it in a document.

To set library item properties:

Select any of the following options:

**Src** displays the filename and location of the source file for the library item. You can’t edit this information.

**Open** opens the library item’s source file for editing. This is equivalent to selecting the item in the Assets panel and clicking the Edit button.

**Detach from Original** breaks the link between the selected library item and its source file. When an item is detached it can be edited in the document, but it’s no longer a library item and can’t be updated when you change the original library item.

**Recreate** overwrites the original library item with the current selection. Use this option to re-create library items if the original library item is missing or has been accidentally deleted.