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Dreamweaver Templates 
A template author designs a "fixed" page layout in a template. The author then creates regions in 
the template that are editable in documents based on that template; if the author does not define a 
region as editable, then template users cannot edit content in that area. Templates enable 
template authors to control which page elements template users--such as writers, graphic artists, 
or other web developers--can edit. There are several types of template regions the template 
author can include in a document. 

One of the most powerful uses of templates is the ability to update multiple pages at once. A 
document that is created from a template remains connected to that template (unless you detach 
the document later). You can modify a template and immediately update the design in all 
documents based on it. 

Creating a Dreamweaver template 
You can create a template from an existing web page, or you can create a template from a new, 
blank document.  After you create the template, you can insert template regions. 

Dreamweaver saves template file in the site’s Templates folder in the local root folder of the site, 
with a .dwt filename extension.  If the Templates folder does not already exist in the site, 
Dreamweaver automatically creates it when you save a new template. 

To use the Assets panel to create a new template 

1. In the Assets panel (Window > Assets), select the Templates category on the left side of 
the panel. 

The Templates category of the Assets panel appears. 

2. Click the New Template button at the bottom of the Assets panel. 

A new, untitled template is added to the list of templates in the Assets panel. 

3. While the template is still selected, enter a name for the template, then press Enter 
(Windows) or Return (Macintosh).  

Dreamweaver creates a new blank template in the Assets panel and in the Templates 
folder. 
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Types of template regions 
Dreamweaver automatically locks most regions of a document when you save the document as a 
template. As a template author you specify which regions of a template-based document will be 
editable by inserting editable regions or editable parameters in the template.  

As you create the template, you can make changes to both editable and locked regions. In a 
document based on the template, however, a template user can make changes only in the editable 
regions; the locked regions can’t be modified. 

There are four types of template regions:  

An editable region is an unlocked region in a template-based document--a section a template 
user can edit. A template author can specify any area of a template as editable. For a template to 
be effective it should contain at least one editable region; otherwise, pages based on the template 
can’t be edited.  

A repeating region is a section of the layout in a document that is set to repeat. For example, 
you can set a table row to repeat. Usually repeating sections are editable so that the template user 
can edit the content in the repeating element, while the design itself is under the control of the 
template author. The template user uses repeat region control options to add or delete copies of 
the repeated region in a document based on the template as necessary.  

There are two types of repeating regions you can insert in a template: repeating region and 
repeating table. 

An optional region is a section of a template that you specify as optional, to hold content such 
as optional text or an image that may or may not appear in a document based on the template. In 
the template-based page, the template user usually controls whether the content is displayed.  

An editable tag attribute lets you unlock a tag attribute in a template, so the attribute can be 
edited in a template-based page. For example, you can "lock" which image appears in the 
document but let the template user set the alignment to left, right, or center.  

Inserting an editable region 
Before you insert an editable region, you should save the document you are working in as a 
template.  

Note: If you insert an editable region in a document rather than a template file, Dreamweaver 
warns you that the document will automatically be saved as a template. 
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To insert an editable template region: 

1. In the Document window, do one of the following to select the region:  

o Select the text or content that you want to set as an editable region.  

o Place the insertion point where you want to insert an editable region.  

2. Do one of the following to insert an editable region:  

o Select Insert > Template Objects > Editable Region.  

o Right-click (Windows) or Control-click (Macintosh), then select Templates > 
New Editable Region.  

o In the Common category of the Insert bar, click the arrow on the Templates 
button, then select Editable Region.  

3. The Editable Region dialog box appears. 

4. In the Name text box, enter a unique name for the region. (You cannot use the same name 
for more than one editable region in a particular template.)  

Note: Do not use special characters in the Name text box.  

5. Click OK.  

The editable region is enclosed in a highlighted rectangular outline in the template, using 
the highlighting color that is set in preferences. A tab at the upper left corner of the region 
shows the name of the region. If you insert an empty editable region in the document, the 
name of the region also appears inside the region. 

Selecting editable regions 
You can easily identify and select template regions in both the template document and template-
based documents. 

To select an editable region in the Document window: 

• Click the tab in the upper left corner of the editable region.  
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To find an editable region and select it in the document: 

• Select Modify > Templates, then select the name of the region from the list at the bottom 
of that submenu.  

Note: Editable regions that are inside a repeated region do not appear in the menu. You 
must locate these regions by looking for tabbed borders in the Document window. 

The editable region is selected in the document. 

Removing an editable region 
If you’ve marked a region of your template file as editable and you want to lock it (make it 
noneditable in template-based documents) again, use the Remove Template Markup command.  

To remove an editable region: 

1. Click the tab in the upper left corner of the editable region to select it.  

2. Do one of the following:  

o Select Modify > Templates > Remove Template Markup.  

o Right-click (Windows) or Control-click (Macintosh), then select Templates > 
Remove Template Markup.  

The region is now no longer editable. 

Creating repeating regions 
A repeating region is a section of a template that can be duplicated as often as desired in a 
template-based page. You typically use repeating regions with tables; however, you can define a 
repeating region for other page elements as well.  

Repeating regions enable you to control your page layout by repeating certain items, such as a 
catalog item and description layout, or a row for data such as a list of items.  

There are two repeating region template objects you can use: repeating region and repeating 
table. 

 
Excerpted from Dreamweaver MX 2004 Help  Page 6 of 14  
Copyright © 1997-2003 Macromedia, Inc. 
 
 



  Dreamweaver Templates 

Creating a repeating region in a template 
Repeating regions enable template users to duplicate a specified region in a template as often as 
desired. A repeating region is not an editable region.  

To make content in a repeating region editable (for example, to allow a user to enter text in a 
table cell in a template-based document), you must insert an editable region in the repeating 
region. 

To insert a repeating region in a template: 

1. In the Document window, do one of the following:  

o Select the text or content you want to set as a repeating region.  

o Place the insertion point in the document where you want to insert the repeating 
region.  

2. Do one of the following, to create a repeating region:  

o Select Insert > Template Objects > Repeating Region.  

o Right-click (Windows) or Control-click (Macintosh), then select Templates > 
New Repeating Region.  

o In the Common category of the Insert bar, click the arrow on the Templates 
button, then select Repeating Region.  

3. The New Repeating Region dialog box appears. 

4. In the Name text box, enter a unique name for the template region. (You cannot use the 
same name for more than one repeating region in a template.)  

Note: When you name a region, do not use special characters.  

5. Click OK.  

The repeating region is inserted in the template. 

Note: A repeating region isn’t editable in the template-based document, unless it contains 
an editable region.  
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Inserting a repeating table 
You can use a repeating table to create an editable region (in table format) with repeating rows. 
You can define table attributes and set which table cells are editable. 

To insert a repeating table: 

1. In the Document window, place the insertion point in the document where you want to 
insert the repeating table.  

2. Do one of the following:  

o Select Insert > Template Objects > Repeating Table.  

o In the Common category of the Insert bar, click the arrow on the Templates 
button, then select Repeating Table.  

3. The Insert Repeating Table dialog box appears. 

4. Enter new values as desired.  

5. Click OK.  

The repeating table appears in the template. 

 

Inserting an optional region 
Use an optional region to control content which may or may not be shown in a template-based 
document. There are two optional region objects:  

• An optional region enables template users to show and hide specially marked regions 
without enabling them to edit the content.  

The template tab of an optional region is preceded by the word if. Based on the condition 
set in the template, a template user can define whether the region is viewable in pages 
they create.  

• An editable optional region enables template users to set whether the region shows or 
hides and enables them to edit content in the region.  
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For example, if the optional region includes an image or text, the template user can set 
whether the content is displayed, as well as make edits to the content if desired. An 
editable region is controlled by a conditional statement.  

To insert an optional region: 
1. In the Document window, select the element you want to set as an optional region.  

2. Do one of the following:  

o Select Insert > Template Objects > Optional Region.  

o Right-click (Windows) or Control-click (Macintosh) the selected content, then 
select Templates > New Optional Region.  

o In the Common category of the Insert bar, click the arrow on the Templates 
button, then select Optional Region.  

3. The Optional Region dialog box appears. 

4. Specify options for the optional region.  

5. Click OK.  

To insert an editable optional region: 
1. In the Document window, place the insertion point where you want to insert the optional 

region.  

Tip: You cannot wrap a selection to create an editable optional region. Insert the region, 
then insert the content in the region. 

2. Do one of the following to open the Optional Region dialog box:  

o Select Insert > Template Objects > Editable Optional Region.  

o In the Common category of the Insert bar, click the arrow on the Templates 
button, then select Editable Optional Region.  

3. The Optional Region dialog box appears. 

4. Enter a name for the optional region, then click the Advanced tab if you want to set 
other options.  

5. Click OK.  
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Setting the optional region dialog box options 
The purpose of this dialog box is to create template parameters and to define conditional 
statements (If...else statements) for template regions. You can use simple true/false operations, or 
define more complex conditional statements and expressions. 

In the Advanced tab you can link multiple optional regions to a named parameter. In the 
template-based document, both regions will show or hide as a unit. For example, you can show a 
"closeout" image and sales price text area for a sale item.  

You can also use the Advanced tab to write a template expression that evaluates a value for the 
optional region and shows it or hides it based on the value. 

To complete the Optional Region dialog box: 
1. In the Basics tab, enter a name for the parameter in the Name text box.  

2. Select the Show By Default checkbox to set the selected region to show in the document. 
Deselect it to set the default value to false.  

Note: To set a different value for the parameter, in Code view locate the parameter in the 
head section of the document and edit the value. 

3. (Optional) Click the Advanced tab, then set the following options:  

o If you want to link optional region parameters, click the Advanced tab, select Use 
Parameter, then from the pop-up menu select the existing parameter you want to 
link the selected content to.  

o If you want to write a template expression to control the display of an optional 
region, click the Advanced tab, select Enter Expression, then enter the expression 
in the text box.  

Note: Dreamweaver automatically inserts double-quotation marks around the text 
you enter. 

4. Click OK.  

When you use the Optional Region template object, Dreamweaver inserts template comments in 
the code. A template parameter is defined in the head section, as in the following example: 

<!-- TemplateParam name="departmentImage" type="boolean" value="true" --> 

At the location where the optional region is inserted, code similar to the code below appears: 

<!-- TemplateBeginIf cond="departmentImage" -->  
<p><img src="/images/airfare_on.gif" width="85" height="22"> </p> 
<!-- TemplateEndIf -->  
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Modifying an optional region 
You can edit optional region settings after you’ve inserted the region in a template. For example, 
you can change whether the default for the content is set to show or not, link a parameter to an 
existing optional region, or modify a template expression. 

To reopen the Optional Region dialog box: 
1. In the Document window, do one of the following:  

o In Design view, click the template tab of the optional region you want to modify.  

o In Design view, place the insertion point in the template region; then in the tag 
selector at the bottom of the Document window, select the template tag, 
<mmtemplate:if>.  

o In Code view, click the comment tag of the template region you want to modify.  

2. In the Property inspector (Window > Properties), click Edit.  

The Optional Region dialog box appears. 

3. Make changes as necessary. . 

4. Click OK.  

Modifying template properties 
When template authors create parameters in a template, documents based on the template 
automatically inherit the parameters and their initial value settings. A template user can update 
editable tag attributes and other template parameters (such as optional region settings).  

To modify an editable tag attribute: 

1. Open the template-based document.  
2. Select Modify > Template Properties.  

The Template Properties dialog box opens, showing a list of available properties. The 
dialog box shows optional regions and editable tag attributes. 

3. In the Name list, select the property.  

The bottom area of the dialog box updates to show the selected property’s label and its 
assigned value. 
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Note: The field name and updateable values are defined in the template. Attributes that 
do not appear in the Name list are not updateable in the template-based document. 

5. Select the Allow Nested Templates to Control This checkbox, if you want to pass the 
editable property along to a documents based on the nested template.  

To modify optional region template parameters: 

1. Open the template-based document.  
2. Select Modify > Template Properties.  

The Template Properties dialog box opens, showing a list of available properties. The 
dialog box shows optional regions and editable tag attributes. 

3. In the Name list, select a property.  

The dialog box updates to show the selected property’s label and its assigned value.  

4. Select the Show checkbox, to show the optional region in the document, or deselect the 
checkbox to hide it.  

Note: The field name and default setting are defined in the template,. 

5. Select the Allow Nested Templates to Control This checkbox, if you want to pass the 
editable property along to a documents based on the nested template.  

Defining editable tag attributes 
You can enable a template user to modify specified tag attributes in a document created from a 
template.  

For example, you can set a background color in the template document, yet enable template users 
to set a different background color for pages they create. Users can update only the attributes you 
specify as editable.  

Specifying editable tag attributes in a 
template 
You can set multiple editable attributes in a page so that template users can modify the attributes 
in template-based documents. The following data types are supported: text, Boolean 
(true/false), color, and URL.  
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To define an editable tag attribute: 

1. In the Document window, select an item you want to set an editable tag attribute for.  

2. Select Modify > Templates > Make Attribute Editable.  

The Editable Tag Attributes dialog box appears. 

Complete the dialog box for each attribute you want to make editable.  

3. Click OK.  

Creating an editable tag attribute inserts a template parameter in the code. An initial value 
for the attribute is set in the template document; when a template-based document is 
created, it inherits the parameter. A template user can then edit the parameter in the 
template-based document  

Modifying template properties 
When template authors create parameters in a template, documents based on the template 
automatically inherit the parameters and their initial value settings. A template user can update 
editable tag attributes and other template parameters (such as optional region settings).  

To modify an editable tag attribute: 
1. Open the template-based document.  

2. Select Modify > Template Properties.  

The Template Properties dialog box opens, showing a list of available properties. The 
dialog box shows optional regions and editable tag attributes. 

3. In the Name list, select the property.  

The bottom area of the dialog box updates to show the selected property’s label and its 
assigned value. 

4. In the field to the right of the property label, edit the value to modify the property in 
the document.  

Note: The field name and updateable values are defined in the template. Attributes that 
do not appear in the Name list are not updateable in the template-based document. 

5. Select the Allow Nested Templates to Control This checkbox, if you want to pass the 
editable property along to a documents based on the nested template.  

To modify optional region template parameters: 
1. Open the template-based document.  

2. Select Modify > Template Properties.  
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The Template Properties dialog box opens, showing a list of available properties. The 
dialog box shows optional regions and editable tag attributes. 

3. In the Name list, select a property.  

The dialog box updates to show the selected property’s label and its assigned value.  

4. Select the Show checkbox, to show the optional region in the document, or deselect the 
checkbox to hide it.  

Note: The field name and default setting are defined in the template,. 

5. Select the Allow Nested Templates to Control This checkbox, if you want to pass the 
editable property along to a documents based on the nested template.  

Creating a document based on a template 
You can use the New Document dialog box to select a template from any of your Dreamweaver-
defined sites or you can use the Assets panel to create a new document from an existing 
template. 

To create a new document based on a template:  
1. Select File > New.  

The New Document dialog box opens.  

2. Click the Templates tab.  

In the Templates For list, select the Dreamweaver site that contains the template you 
want use, then select a template from the list on the right.  

3. Click Create.  

The new document opens in the Document window. 

4. Save the document.  

To create a new document from a template in the Assets panel:  
Open the Assets panel (Window > Assets), if it is not already open.  

1. In the Assets panel, click the Templates icon on the left to view the list of templates in 
your current site. 

Tip: If you just created the template you want to apply, you might need to click the 
Refresh button to see it. 

2. Right-click (Windows) or Control-click (Macintosh) the template you want to apply, then 
select New From Template.  

The document opens in the Document window. 
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